くうと徒然なるままに

ゆるふわ を志向している なごやかです。

Xamarin.Adnroid でエラーが出た Error:java.lang.UnsupportedClassVersionError:com/android/dx/command/Main : CreateDatabaseWithAdoNet

Xamarin.Android でアプリの環境を構築してたらエラーが出た Error:java.lang.UnsupportedClassVersionError:com/android/dx/command/Main : CreateDatabaseWithAdoNet

原因

JDK 7 をインストールしていたから、JDK8をインストールするべきであった

解決方法

JDK 8 をダウンロードする

Java SE Development Kit 8 - Downloads

Visual Studio 上のXamarin の設定を変える

f:id:kuxumarin:20160922002138p:plain

たぶん、これでエラーは出なくなったはずです。

この記事は以下のサイトを参考にしました

forums.xamarin.com