読者です 読者をやめる 読者になる 読者になる

くうと徒然なるままに

超高校生級のXamariner です。

Xamarin 4.3.0.784 にしたら、Your Java version (1.7.0) is too old. You must have at least 1.8 installed. ってでたから、解決してみた

困ってたこと

Your Java version (1.7.0) is too old. You must have at least 1.8 installed. のため、プロジェクト {Project Name} は Android 7.1 (API レベル 25 - Nougat) を使用してビルドできません それをインストールするか、[ツール] -> [オプション] -> [Xamarin] -> [Android 設定] メニューで Oracle 1.8+ 用の Java Development Kit パスを設定してください.

ってエラーが出てた

https://lh3.googleusercontent.com/-232okkTTyqA/WLIREM6Zx-I/AAAAAAAAYbg/cwBklpRUrcY/s0/devenv_2017-02-24_02-15-07.png

環境

やったこと

1. 最新版の JDK をインストールした

http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.htmlwww.oracle.com

https://lh3.googleusercontent.com/-5_YCr8hosa4/WLIQno3TZUI/AAAAAAAAYbY/iL_BJSuv18k/s0/msiexec_2017-02-24_02-20-45.pnglh3.googleusercontent.com

2. Visual Studio の設定より使用するJDK を変更した

https://lh3.googleusercontent.com/-FasM_zjq8rQ/WLIQuW1ZMZI/AAAAAAAAYbc/enaqaZWC64E/s0/devenv_2017-02-24_02-45-27.pnglh3.googleusercontent.com