くうと徒然なるままに

ゆるふわ を志向している なごやかです。

Xamarin Forms Preview で **Unsupported Java Version Detected** ってエラーメッセージが出たから解決してみた。

Xamarin Forms Preview で Unsupported Java Version Detected ってエラーメッセージが出たから解決してみた。

エラーメッセージ

The previewer requires a 64-bit version of Oracle Java JDK 8 (1.8) or higher. Please install it and then set the Java JDK location in the Xamarin Studio or Visual Studio preferences.

解決方法

64 bit バージョンの JDK をインストールする

http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.htmlwww.oracle.com

難しいところ

Visual Studio 2017 のインストーラーがデフォでインストールするのが、 32 bit バージョンだということです。