くうと徒然なるままに

ゆるふわ を志向している なごやかです。

Ruby 2.5, Rails 5.2.0 Beta2 を Mac に導入する

こちらのイベントに参加する為の環境構築をしたメモです。

othlotech.connpass.com

必要な環境

前提条件

  • macOS 最新版@18.1
  • HomeBrew

現状

最初から Ruby 2.4 が入ってました。

Rails は 5.1.4

Ruby のアップグレード

Rails は最新版の Ruby が入ってないと導入できないっぽい

HomeBrew の力を借りますw

$ brew upgrade ruby

Rails のアップグレード

$ gem install rails -v 2.5.0.Beta2

完成